CentOS LNMP WordPress自动更新需填写FTP解决方法

无论是使用阿里云还是其他云 VPS 下的 Linux + LNMP 一键安装包环境,安装 WordPress 后,遇上提示更新升级的时候,都会出现需要填写 FTP 相关信息的情况,相当不方便。不过,根据 LNMP 作者军哥的博客提示,只需要在服务器内做一些文件权限的修改变可以。

这个问题的产生,主要是网站目录的权限执行身份非文件属主身份。

解决方法如下:

假设你的 WordPress 安装目录为 /home/wwwroot/lnmp.org

用 Putty 登录 Linux VPS ,执行:chown -R www /home/wwwroot/lnmp.org

执行上面的命令就可以将 /home/wwwroot/lnmp.org 下所有文件的属主改为 www ,这样就可以解决自动更新必须填FTP的问题。

基本上按以上方法就可以解决问题,如果还不能正常成功更新,可以尝试修改 wp-config.php 文件

在 wp-config.php 中加入一行代码

define('FS_METHOD', "direct");  

如此就能可以在后台点击更新升级。

原文出处:艾码汇 -> https://www.imahui.com/network/633.html

相关推荐

发表回复

房先生
我们将24小时内回复。
2024-05-24 19:32:09
您好,有任何疑问请与我们联系!
您的工单我们已经收到,我们将会尽快跟您联系!
[加我微信]
chaoneo
注:点击复制微信号并打开微信APP,添加好友后进行聊天。
[电话联系]
13585372227
[电子邮件]
chaoneo@163.com
取消

选择聊天工具: